Ubuntu has since changed its mind and says it will continue to package select 32-bit libraries. See our post for more details.

Ubuntu has confirmed plans to drop all support for 32-bit (i386) systems going forward, beginning with the upcoming Ubuntu 19.10 release.

The decision will mean that the distro no longer builds, packages or distributes any 32-bit software, libraries or tools on newer versions of Ubuntu.

Users of Ubuntu 18.04 LTS 32-bit are not affected by today’s announcement and will (should?) continue to work as normal, with access to the existing 32-bit archive.

But the move will mean they are unable to upgrade to a newer Ubuntu release — nope, not even the next LTS!

Will such a major sounding change have much of an impact?

Eh, no, not really.

Ubuntu says it’s stranding a mere 1% of its current user base on 32-bit version Ubuntu 18.04 LTS (which isn’t terrible place to stay, as it is supported until 2023).

Why is Ubuntu dropping 32-bit support?

In a post to the Ubuntu Developer Mailing List Canonical’s Steve Langasek explains the decision.

Ubuntu say maintaining packages for the i386 architecture is more hassle than its worth

Langasek says “…Ubuntu engineering team has reviewed the facts before us and concluded that we should not continue to carry i386 forward as an architecture.

Adding that “…i386 will not be included as an architecture for the 19.10 release, and we will shortly begin the process of disabling it for the eoan series across Ubuntu infrastructure.”

Ubuntu dropped 32-bit install images in 2017, and a slew of distros and software vendors have followed suit since, all retiring support for i386 systems.

So it was only a matter of time before it phased out the 32-bit archive too.

Maintaining packages for the i386 architecture is simply more hassle than its worth with only around 1% of Ubuntu’s current user base running 32-bit systems.

What happens to {distro}?

Naturally the move will have a knock on effect on Linux distros based on Ubuntu.

Derivatives like Linux Mint will be forced to go 64-bit only (most already have) for future releases, lest they opt to create and maintain their own 32-bit archive.

They also reference the ‘lack of support’ in the upstream Linux kernel and toolchains for such systems, as well as the slow availability of security patches being made available, and the general trend in desktop apps ditching 32-bit builds.

What happens to {32-bit app}?

Most Ubuntu users run 64-bit systems, but there are still apps that depend on or requires some 32-bit libraries (*cough*steam*cough*) or multilib function — If those libraries are no longer being built, and no longer available, what happens to the software that needs them?

Well, I don’t know the answer, but Will Cookie reassures devs, saying that: “…there are a number of ways that 32-bit applications can continue to be made available to users of later Ubuntu releases“, and name-checks LXD and Snappy.

I mean, a lot of folks still depend on Wine to run 32-bit Windows software (and Wine on 64-bit Ubuntu requires the 32-bit repo to be enabled).

How that’s tackled remains to be seen. For now, expect a few bumps in the road as Ubuntu starts out on a 64-bit only journey.

Is this decision fair? Share your thoughts in the comments
News
#32bit #Canonical #disco dingo #Ubuntu 19.10