Submit A Tip Alternative Tip Form

DiRT Rally: Linux System Requirements Revealed

Last week brought word that a DiRT Rally Linux port will launch next month  — but you might have been stalling,  wondering what the system requirements for the racing game might be?

Well, we’ve some more information.

Or, more accurately, Feral Interactive, the publishers behind the Linux port, do. The company has dished the dirt on the DiRT Rally Linux system requirements ahead of its release on March 2.

If you’re running some obscure Linux distro on a fairly hum-drum laptop, you will want to look away now.

Dirt Rally Linux System Requirements

The minimum system requirements for DiRT Rally on Linux ask for:

  • Intel Core i3-4130T or AMD FX6300
  • 8GB RAM
  • 1GB NVIDIA 650ti or AMD R9 270 graphics card (or better)
  • Ubuntu 16.10 (64-bit)

But to hit recommended system requirements for DiRT Rally on Linux requires:

  • Intel Core i7-4770
  • 8GB RAM
  • 4GB NVIDIA 970 graphics card (or better)
  • Ubuntu 16.10 (64-bit)

In both instances NVIDIA graphics cards need to be running driver version 370.28, while AMD graphics cards require MESA 13.0.2+.

Will you be buying the game?